| Home » Categories » Multiple Categories |
My application pool stops working. What is wrong with my site? |
|
Article Number: 300 | Rating: 1/5 from 1 votes | Last Updated: Wed, Sep 24, 2025 at 12:08 AM
|
| Sometimes, you will notice that your website's application pool is halted automatically by the IIS. If this happens, there are few causes: 1. Something is not right with your website's coding. For the details of the error message, you can always ask our Support Team to review the Windows Event Viewer and we will send it to you. Please do take note that Windows Event Viewer is not verbose and not all the website's error messages are logged there. 2. Your website is using higher-than-usual CPU or RAM, which causes the IIS to automatically halt your site. So, what can you do? You need to ensure that every single part of your website is fully optimized. This includes image optimization, SQL Query optimization, Database Optimization, etc. You may sometime experience this issue on a shared server. Since there are other clients on the shared server, their existence may increase the resources usages and at one point, the IIS will crash and stop several sites automatically in order to bring down the resources usages. If you are on our dedicated server service, then you know directly it is the time for you to upgrade to a better server with better CPU and RAM |
Attachments
There are no attachments for this article.
|
My website session times out earlier than expected. Why?
Viewed 5532 times since Tue, May 1, 2012
Do you support ASP.NET MVC 6?
Viewed 5517 times since Wed, Feb 17, 2016
Will my Crystal Report XI (Crystal Report 11) work on your server?
Viewed 3262 times since Tue, May 1, 2012
How often do you backup my website?
Viewed 5475 times since Tue, May 1, 2012
How to Solve the error: "405 - HTTP verb used to access this page is not allowed"?
Viewed 6105 times since Wed, Oct 24, 2018
Sample Code to Send email using ASP.NET 2
Viewed 10296 times since Tue, May 1, 2012
Monitoring Tools For Windows
Viewed 1786 times since Wed, Jul 13, 2022
I get an error Server.CreateObject Failed when I try to use CDONTs. What can I do?
Viewed 3488 times since Tue, May 1, 2012
About Azure Key Vault
Viewed 2510 times since Mon, Nov 2, 2020
You informed me that my Crystal Report has been configured, why do I still receive an error message?
Viewed 3531 times since Tue, May 1, 2012
|
