Home » Categories » Multiple Categories

I receive this error message: "Unknown file type (binary data)" when trying to deploy my SQL CE database. What did I do wrong?

If you receive this error message, please try adding the following line to your web.config file:

<identity impersonate="true" userName="XXXXXXXXX" password="XXXXXX" />

This line should be added inside the tag <system.web> </system.web>. Username and password can be your login credentials for the system.

Therefore, the following is the whole web.config-content with which everything works:

<?xml version="1.0" encoding="UTF-8"?>
     <configuration>
          <system.data>
                 <DbProviderFactories>
                          <remove invariant="System.Data.SqlServerCe.4.0" />
                          <add invariant="System.Data.SqlServerCe.4.0" name="Microsoft® SQL Server® Compact 4.0" description=".NET Framework Data Provider for Microsoft SQL Server Compact" type="System.Data.SqlServerCe.SqlCeProviderFactory, System.Data.SqlServerCe, Version=4.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" />
                 </DbProviderFactories>
          </system.data>
       <system.web>
           <identity impersonate="true" userName="???" password="???" />
       </system.web>
</configuration>

Please note that our Control Panel does not really accept the .cshtml-files (webpages) and the .sdf-file (database) and you will always see the error message: "Unknown file type (binary data)". However, please just ignore the error message and by following the above guideline, everything will work as expected.



 

Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Will my Crystal Report XI (Crystal Report 11) work on your server?
Viewed 3274 times since Tue, May 1, 2012
How can I deploy my VS LightSwitch project on your server?
Viewed 4485 times since Tue, May 22, 2012
Will my Crystal Report X (Crystal Report 10) work on your server?
Viewed 3194 times since Tue, May 1, 2012
Do you support SQL 2012?
Viewed 3891 times since Fri, May 4, 2012
I cannot browse to my site via the IP Address directly. What is wrong?
Viewed 5196 times since Mon, May 7, 2012
Can I have more than one MySQL database on my hosting account?
Viewed 9074 times since Tue, May 1, 2012
Why do I receive "Server Unavailable" message after Crystal Report configuration?
Viewed 3433 times since Tue, May 1, 2012
What is the connection string for my MySQL database?
Viewed 4813 times since Mon, May 7, 2012
Can I have more than one MS SQL database on my hosting account?
Viewed 4325 times since Tue, May 1, 2012